ttmap won't switch to ttnavigator

If you think you have detected a bug, please share any problems found here, giving all necessary details.

ttmap won't switch to ttnavigator

Postby dzevo » 01 Dec 2011, 20:25

I install last ttmap from your website ver 0.6.1 prog works ok but now wont switch to TomTomNavigator what to do?
I tried Power Down or click to TomTomNavigAtor but always after restart by itself th TomTom XL start ttmap.
The radical way is to delete the ttmap from memory of XL but any non destructive way ?

Here is paste of ttgo.bif
[TomTomGo]
DeviceName=TomTom XL
DeviceVersionHW=ONE XL (v9)
DeviceSerialNumber=RC4208J04915
DeviceUniqueID=AKVHW BJH76
RamDiskVersion=20080328
BootLoaderVersion=55011
LinuxVersion=166324
ApplicationVersionVersionNumber=7521
ApplicationVersion=9262
UserLanguage=English UK
UserName=
LastConnectionTime=Never
GPSFirmwareVersion=
BuiltInColorScheme0=Belgica
BuiltInColorScheme1=Brittanica
BuiltInColorScheme2=America
BuiltInColorScheme3=Germanica
BuiltInColorScheme4=Australia
BuiltInColorScheme5=Deuteranopia
BuiltInColorScheme6=Greys
BuiltInColorScheme7=Antarctica
BuiltInColorScheme8=Africa
BuiltInColorScheme9=Astra
CurrentColorSchemeBuiltIn=4
CurrentVoiceInfo=Goran
CurrentMap=Western_and_Central_Europe_2GB
CurrentMapVersion=715.1730
CurrentHomeLocation=45.53026,13.73440,Unnamed road
Traffic=N
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby dzevo » 01 Dec 2011, 20:48

I tried delete all the ttmaps directories also the Maps dir with maps.idx but file maps.idx won't be deleted although the file have size 0, and no files in Maps dir or subdirs.
Ok after this try I put back all again like before and after 10 tries finally get switching from ttmaps to ttnavigator, after check if ttnavigator work ok and it was,
i was in dillema what to do because ttmpas won't switch always to ttnavigator.

Next was trying to install or update the navcore (decide to put version 8 over version 7) and i get the 2 files from other forum but didn't know how to install without tthome installed on the PC.
So I installed tthome on my PC (reading on other forum people suggest not to use tthome becuse after update it scramble tomtom and make it unusable), so knowing this I decide to anyway use tthome to update the navcore and update all other software from tomtom manufacturer support site, like was assumed
after update (i check that tthome said "there is no other update for your tomtom device") my tomtom was unusable, when booting it load the start picture and get frozen in the middle of nothing just the picture.
So now I must overwrite all with the backup data from tomtom, I made earlier before the upgrade.
For transferring files to tomtom I use WinCommander for sure and exact files copy, when tomtom connected to the PC via USB cable.

I would like get answer how install new navcore manually on tomtom or link will be great.
Where is the log of ttmaps in witch folder or in root ? If deleted ttmaps will create new one by itself or not ?
Also where is the ttnavigator appz log file also in root? and how to trace and where what stopped the butting of tomtom after update?

Regards
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby jcr83 » 01 Dec 2011, 21:03

You have probably selected the "Autorun mode" in ttMaps, that's why ttMaps starts automatically when you switch the TomTom on. Look at the setup menu documentation : http://ttmaps.free.fr/en/manual.html#10
If the problem is still there after you have disabled the "Autorun mode", please send the ttmaps.log file which is in the ttMaps directory.
jcr83
Site Admin
 
Posts: 1063
Joined: 25 Oct 2010, 16:42

Re: ttmap won't switch to ttnavigator

Postby dzevo » 02 Dec 2011, 18:31

here is copy/paste of ttmaps.log

Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Default battery type = 1
Current time : 1322521126 , GPS time : 2082980726
Setting the time : 03/01/2036 13:45:26
Can't create track file : /mnt/sdcard/ttMaps/Tracks/20360103_134526.trk
Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can't read the configuration file
Current time : 1322521248 , GPS time : 2082980726
Setting the time : 03/01/2036 13:45:26
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
No map sets found in directory :"/mnt/sdcard/ttMaps/Maps"
Brightness = 100
Input thread terminated
Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can't read the configuration file
Current time : 1322521498 , GPS time : 2082980726
Setting the time : 03/01/2036 13:45:26
Can not set the locale
Can not set the locale for language en_EN
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
Can't write the configuration file
Brightness = 100
Segmentation fault
Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can not set the locale for language en_EN
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
Current time : 1322521550 , GPS time : 2082980724
Setting the time : 03/01/2036 13:45:24
Brightness = 100
Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can not set the locale for language en_EN
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
Brightness = 100
Current time : 1322521743 , GPS time : 2082980726
Setting the time : 03/01/2036 13:45:26
Application Version=75
Main Version=7
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can not set the locale for language en_EN
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
Brightness = 100
Current time : 1322522572 , GPS time : 2082980726
Setting the time : 03/01/2036 13:45:26
Can't write the configuration file
Can't write the configuration file
Can't write the configuration file
Can not set the locale
Can't write the configuration file
EuFC06Complet.ecw
Can't write the configuration file
Error 'Read-only file system' while renaming EuFC06Complet to EuFC06Complet@
Can't write the configuration file
Cannot write to map index file
Can't write the configuration file
No map available
Can't write the configuration file
sql=SELECT comments FROM param ORDER BY comments LIMIT 0,7
EuFC06Complet.ecw
Error 'No such file or directory' while renaming Єю to Єю@
Can't write the configuration file
ON/OFF button pressed
Brightness = 100
ON/OFF button pressed
Suspending ...
* Running suspend tasks
* Stop gltt
Stopping gltt
Stopping 1
Stopping break
mv: /var/log/gl/*: No such file or directory
* NOT starting Bluetooth
* Suspend tasks done
ON/OFF button pressed
* Running resume tasks
* Starting gltt normal
mknod: /var/run/gpspipe: File exists
* requesting PnP hardware rescan
* Resume tasks done
Resuming ...
Brightness = 100
Application Version=
Main Version=
Battery Type=
The ttgo.bif file is missing.
Application Version=
Main Version=
Battery Type=
The ttgo.bif file is missing.
Application Version=
Main Version=
Battery Type=
The ttgo.bif file is missing.
Application Version=
Main Version=
Battery Type=
The ttgo.bif file is missing.
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby dzevo » 02 Dec 2011, 18:44

I look at the ttmaps log and saw there is "ttgo.bif file is missing."
so I copied from my backup into folder f:/ttMaps/ttmaps.log
After this tomtom booted normaly into ttmaps again also I found that start up was withou red cross
so now after menu->Preference->No auto run (red cross appears)-> Done -> Power Down
after reboot tomtom boot again first into ttMaps!
I discovered that ttMaps wont remember my last choice to stop auto run because after reboot auto run is active again NO red cross!

Ok now again I have red cross over auto run (disabled) and try to Shut Down to see what happened
after auto reboot of tomtom again boot first ttMaps !
How to boot into ttNavigator again ?

Please Help
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby jcr83 » 03 Dec 2011, 14:15

I think there is a problem with the SD card, because there are lots of messages "Can't write the configuration file". May be your SD card is full ?
Also the missing file ttgo.bif shows that there is a problem. This file is always present on TomTom GPS.

Until you have solved these problems, remove the ttn file on the SD card, to avoid that ttMaps starts every time.
jcr83
Site Admin
 
Posts: 1063
Joined: 25 Oct 2010, 16:42

Re: ttmap won't switch to ttnavigator

Postby dzevo » 03 Dec 2011, 23:16

>>I think there is a problem with the SD card, because there are lots of messages "Can't write the configuration file". May be your SD card is full ?
My TomTom XL Canada 310 do not have SD slot and SD card only the default FLASH memory 2Gb total. There is also about 370 Mb free disk(memory) space.

>>Also the missing file ttgo.bif shows that there is a problem. This file is always present on TomTom GPS.
Read my last post I copied ttgo.bif into root and now ttMaps noramly boot, first in GPS locator, also can't get enought satellite together to get GPS location and time,
could be also the probblem for ttMaps to function normally?

>>Until you have solved these problems, remove the ttn file on the SD card, to avoid that ttMaps starts every time.lways present on TomTom GPS.
Please be more specific "remove the ttn file on the SD card" what ttn file ? all file extension with this start name ?

Thank You for help so farr ... :roll:
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby jcr83 » 05 Dec 2011, 12:12

The file ttn is created by ttMaps and saved at the root of the SD card (or movinand on models that have no SD card slot) when you decide to use the autorun mode.
Since it seems that you can't get rid of this mode, I suggested you to remove this file.
Now, it is important to check that you don't have any more error messages like "Can't write the configuration file".
jcr83
Site Admin
 
Posts: 1063
Joined: 25 Oct 2010, 16:42

Re: ttmap won't switch to ttnavigator

Postby dzevo » 06 Dec 2011, 01:20

Hello again this is ttMaps.log file

Application Version=80
Main Version=8
Battery Type=
ttMaps version 0.6.1
Frame buffer X Resolution : 480
Frame buffer Y Resolution : 272
Frame buffer Stride : 960
Screen 480 x 272 (widescreen)
/sys/class/backlight/s3c/brightness opened successfully
Brightness = 100
Watchdog activated
ttgo_touchscreen: Opened successfully '/dev/ts'.
gpstype = 129
Default geoid correction = TRUE
Can't read the configuration file
Can not set the locale
Can not set the locale for language en_EN
Can't open POI database: unable to open database file
OV2 directory : /mnt/sdcard/Western_and_Central_Europe_2GB/
No map sets found in directory :"/mnt/sdcard/ttMaps/Maps"
Brightness = 100
Closing GPS thread ...
Waiting for GPS thread
Input thread terminated
GPS thread terminated
GPS reinitialized
Geoid instance destroyed
Closing POIs ...
Closing proj ...
Closing maps ...
Closing backlight ...
Brightness = 100
Closing screen ...
Closing watchdog ...
Terminating ...
ttMaps return code = 79
Relaunch ttn

Can You see something wrong ? I install new navcore first num 9.205 but my default Map version 715.1730 won't work with this navcore,
so I install navcore 7.522.9270 over it and again my default maps ver 715.1730 and finally ttMAPS.
seems to work all ok, so now need put my country maps into ttMpas/Maps/ folder
The map files are one name.png and other name.map made in OziExplorer bellof is a copy of one .map file
Can I use those files or must all convert into ecw files please advice program or fast conversion protocol.

name.maps file
1 ,Map Code,
WGS 84,WGS 84, 0.0000, 0.0000,WGS 84
Reserved 1
Reserved 2
Magnetic Variation,,,E
Map Projection,Transverse Mercator,PolyCal,No,AutoCalOnly,No,BSBUseWPX,No
Point01,xy, 380, 0,in, deg, 45,29.98038,N, 13,29.72472,E, grid, , , ,N
Point02,xy, 5267, 90,in, deg, 45,29.98068,N, 13,37.22376,E, grid, , , ,N
Point03,xy, 5148, 7027,in, deg, 45,22.48158,N, 13,37.22436,E, grid, , , ,N
Point04,xy, 254, 6941,in, deg, 45,22.48128,N, 13,29.72532,E, grid, , , ,N
Point05,xy, , ,in, deg, , ,N, , ,E, grid, , , ,N
Point06,xy, , ,in, deg, , ,N, , ,E, grid, , , ,N
Point07,xy, , ,in, deg, , ,N, , ,E, grid, , , ,N
Point08,xy, , ,in, deg, , ,N, , ,E, grid, , , ,N
Point09,xy, , ,in, deg, , ,N, , ,E, grid, , , ,N
Point10,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point11,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point12,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point13,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point14,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point15,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point16,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point17,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point18,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point19,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point20,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point21,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point22,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point23,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point24,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point25,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point26,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point27,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point28,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point29,xy, , ,in, deg, , ,, , ,, grid, , , ,
Point30,xy, , ,in, deg, , ,, , ,, grid, , , ,
Projection Setup, 0.000000000, 14.995222222, 0.999900000, 5500000.00, -473.00,,,,,
Map Feature = MF ; Map Comment = MC These follow if they exist
Track File = TF These follow if they exist
Moving Map Parameters = MM? These follow if they exist
MM0,Yes
MMPNUM,4
MMPXY,1,0,0
MMPXY,2,5268,0
MMPXY,3,5268,7029
MMPXY,4,0,7029
MMPLL,1, 13.485668, 45.499561
MMPLL,2, 13.620407, 45.501281
MMPLL,3, 13.623445, 45.374712
MMPLL,4, 13.489006, 45.373000
MM1B,1.998867
MOP,Map Open Position,0,0
IWH,Map Image Width/Height,5268,7029
dzevo
 
Posts: 6
Joined: 28 Nov 2011, 19:38

Re: ttmap won't switch to ttnavigator

Postby jcr83 » 06 Dec 2011, 08:49

dzevo wrote:Can You see something wrong ?

Yes, you haven't installed any maps :
No map sets found in directory :"/mnt/sdcard/ttMaps/Maps"

Please read the documentation on the web site.

Since the problem "ttmap won't switch to ttnavigator" is solved, I close this topic.
jcr83
Site Admin
 
Posts: 1063
Joined: 25 Oct 2010, 16:42


Return to Problems with ttMaps

Who is online

Users browsing this forum: No registered users and 0 guests